summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb b/external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
new file mode 100644
index 00000000..08201695
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-grpcio-tools_1.14.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Protobuf code generator for gRPC"
+DESCRIPTION = "Google gRPC tools"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
+
+SRC_URI[md5sum] = "b2fabfb54c7824c1e49a02de2aa6628e"
+SRC_URI[sha256sum] = "4ce5aa660d7884f23aac1eafa93b97a4c3e2b512edff871e91fdb6ee86ebd5ea"
+
+DEPENDS_append = " ${PYTHON_PN}-grpcio"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "${PYTHON_PN}-grpcio"
+
+BBCLASSEXTEND = "native nativesdk"