summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb b/external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb
new file mode 100644
index 00000000..0a365ffe
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-jsonpointer_2.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Resolve JSON Pointers in Python"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
+
+SRC_URI[md5sum] = "741b98d0e693b08b5e44e0a9da5a7bb7"
+SRC_URI[sha256sum] = "c192ba86648e05fdae4f08a17ec25180a9aef5008d973407b581798a83975362"
+
+inherit pypi setuptools
+
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-re \
+"
+
+BBCLASSEXTEND = "native nativesdk"