summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb b/external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb
new file mode 100644
index 00000000..8caccd26
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-license-expression_1.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
+HOMEPAGE = "https://github.com/nexB/license-expression"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "fd4cb295cc345be1071274cdbd81c969"
+SRC_URI[sha256sum] = "7960e1dfdf20d127e75ead931476f2b5c7556df05b117a73880b22ade17d1abc"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-booleanpy \
+ "
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-logging \
+ "
+
+BBCLASSEXTEND = "native nativesdk"