summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb b/external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb
new file mode 100644
index 00000000..4da22923
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pybluez_0.22.bb
@@ -0,0 +1,25 @@
+
+SUMMARY = "Bluetooth Python extension module"
+DESCRIPTION = "Bluetooth Python extension module"
+HOMEPAGE = "https://pybluez.readthedocs.io/"
+SECTION = "devel/python"
+
+DEPENDS = "bluez5"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+
+SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
+SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
+
+S = "${WORKDIR}/PyBluez-${PV}"
+
+PYPI_PACKAGE = "PyBluez"
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ ${PYTHON_PN}-fcntl \
+"