summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb b/external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb
new file mode 100644
index 00000000..2ef23149
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pysocks_1.7.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A Python SOCKS client module"
+DESCRIPTION = "PySocks lets you send traffic through SOCKS and HTTP proxy \
+servers. It is a modern fork of SocksiPy with bug fixes and extra features."
+HOMEPAGE = "https://github.com/Anorov/PySocks"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1d457bcffb9661b45f799d4efee72f16"
+
+SRC_URI[md5sum] = "89b1a6865c61bae67a32417517612ee6"
+SRC_URI[sha256sum] = "3f8804571ebe159c380ac6de37643bb4685970655d3bba243530d6558b799aa0"
+
+PYPI_PACKAGE = "PySocks"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"