summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb b/external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb
new file mode 100644
index 00000000..55fda2f0
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pytest-runner_5.2.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
+SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
+
+inherit pypi setuptools
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io"
+
+# Dependency only exists for python2
+RDEPENDS_${PN} += "python-argparse python-compiler"
+
+BBCLASSEXTEND = "native nativesdk"