summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb b/external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
new file mode 100644
index 00000000..44c9505b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
@@ -0,0 +1,12 @@
+SUMMARY = "functools.singledispatch from Python 3.4"
+DESCRIPTION = "PEP 443 proposed to expose a mechanism in the functools standard library module \
+in Python 3.4 that provides a simple form of generic programming known as single-dispatch \
+generic functions. This library is a backport of this functionality to Python 2.6 - 3.3"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=ee3cd67264adc7eb07981f3644dc17dc"
+
+SRC_URI[md5sum] = "af2fc6a3d6cc5a02d0bf54d909785fcb"
+SRC_URI[sha256sum] = "5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c"
+
+inherit pypi setuptools