summaryrefslogtreecommitdiffstats
path: root/external/meta-qt5/recipes-qt/examples
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-qt5/recipes-qt/examples
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-qt5/recipes-qt/examples')
-rw-r--r--external/meta-qt5/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch48
-rw-r--r--external/meta-qt5/recipes-qt/examples/cinematicexperience_1.0.bb40
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5-opengles2-test_git.bb19
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5everywheredemo_1.0.bb25
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5ledscreen_1.0.bb23
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb26
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5nmapper/change-property-string.patch26
-rw-r--r--external/meta-qt5/recipes-qt/examples/qt5nmapper_1.0.bb28
-rw-r--r--external/meta-qt5/recipes-qt/examples/qtsmarthome_1.0.bb27
-rw-r--r--external/meta-qt5/recipes-qt/examples/quitbattery_1.0.0.bb25
-rw-r--r--external/meta-qt5/recipes-qt/examples/quitindicators_1.0.1.bb24
11 files changed, 311 insertions, 0 deletions
diff --git a/external/meta-qt5/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch b/external/meta-qt5/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch
new file mode 100644
index 00000000..fc132ecc
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch
@@ -0,0 +1,48 @@
+Index: Qt5_CinematicExperience_rpi_1.0/content/SettingsView.qml
+===================================================================
+--- Qt5_CinematicExperience_rpi_1.0.orig/content/SettingsView.qml
++++ Qt5_CinematicExperience_rpi_1.0/content/SettingsView.qml
+@@ -127,8 +127,8 @@ Item {
+ Switch {
+ text: "Do you l-o-v-e colors?"
+ checked: settings.showColors
+- onText: "Yes"
+- offText: "No!"
++ textON: "Yes"
++ textOFF: "No!"
+ onCheckedChanged: {
+ settings.showColors = checked;
+ }
+Index: Qt5_CinematicExperience_rpi_1.0/content/Switch.qml
+===================================================================
+--- Qt5_CinematicExperience_rpi_1.0.orig/content/Switch.qml
++++ Qt5_CinematicExperience_rpi_1.0/content/Switch.qml
+@@ -6,8 +6,8 @@ Item {
+
+ property alias text: textItem.text
+ property bool checked: false
+- property string onText: "On"
+- property string offText: "Off"
++ property string textON: "On"
++ property string textOFF: "Off"
+
+ QtObject {
+ id: priv
+@@ -120,7 +120,7 @@ Item {
+ color: "#000000"
+ font.pixelSize: 18
+ font.bold: true
+- text: onText
++ text: textON
+ }
+ Text {
+ anchors.verticalCenter: parent.verticalCenter
+@@ -129,7 +129,7 @@ Item {
+ color: "#ffffff"
+ font.pixelSize: 18
+ font.bold: true
+- text: offText
++ text: textOFF
+ }
+
+ Image {
diff --git a/external/meta-qt5/recipes-qt/examples/cinematicexperience_1.0.bb b/external/meta-qt5/recipes-qt/examples/cinematicexperience_1.0.bb
new file mode 100644
index 00000000..9a90f1d4
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/cinematicexperience_1.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Qt5 technology demo"
+DESCRIPTION = "Cinematic Experience collects many of the new Qt5 QtQuick 2.0 features into the same UX demo application. It uses particles, sprites, path animation, custom shaders etc. features which Qt5 introduces for QML UIs."
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=38;endline=50;md5=51babd597624b70752069953876aaa18"
+
+SRC_URI = "http://quitcoding.com/download/Qt5_CinematicExperience_rpi_1.0.tgz"
+SRC_URI += "file://fix_qt5_3_compatibility.patch"
+
+SRC_URI[md5sum] = "935a5db0a6b2a72c67236e72f52be7d1"
+SRC_URI[sha256sum] = "0dd602983ced5f7c0cfd5ad0fbfe2b0b7e3c9ff715e4ef23eef818ccc2b6c60b"
+
+S = "${WORKDIR}/Qt5_CinematicExperience_rpi_${PV}/"
+
+# other version available for small screens
+#SRC_URI = "http://quitcoding.com/download/Qt5_CinematicExperience_1.0.tgz"
+#SRC_URI[md5sum] = "1c4f9bf5411c985fc5d3dbfc5d826a29"
+#SRC_URI[sha256sum] = "0e547e0259667915a24e84ade5efdcd0c553f81786734452c2c8dbce19a19f44"
+#S = "${WORKDIR}/Qt5_CinematicExperience_${PV}/"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+RDEPENDS_${PN} = "liberation-fonts qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/Qt5_CinematicExperience ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/content ${D}${datadir}/${P}
+ install -m 0644 ${S}/Qt5_CinematicExperience.qml ${D}${datadir}/${P}
+
+ install -d ${D}${bindir}
+ echo "#!/bin/sh" > ${D}${bindir}/Qt5_CinematicExperience
+ echo "export QML_IMPORT_PATH=${datadir}/${P}" >> ${D}${bindir}/Qt5_CinematicExperience
+ echo "export QML2_IMPORT_PATH=${datadir}/${P}" >> ${D}${bindir}/Qt5_CinematicExperience
+ echo "${datadir}/${P}/Qt5_CinematicExperience \$* " >> ${D}${bindir}/Qt5_CinematicExperience
+ chmod +x ${D}${bindir}/Qt5_CinematicExperience
+}
+
+FILES_${PN} += "${datadir}"
diff --git a/external/meta-qt5/recipes-qt/examples/qt5-opengles2-test_git.bb b/external/meta-qt5/recipes-qt/examples/qt5-opengles2-test_git.bb
new file mode 100644
index 00000000..5da25dc9
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5-opengles2-test_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Qt5 OpenGL ES 2.0 Test Application"
+DESCRIPTION = "This application is used to test OpenGL ES 2.0 rendering \
+in a simple QWindow, plus multi-touch input, window orientation, window \
+focus handling and some other game-related features."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/main.cpp;beginline=1;endline=26;md5=93b83ece006c9e76b9fca80c3aecb169"
+
+PV = "1.0.4+gitr${SRCPV}"
+
+DEPENDS = "qtbase qtsensors"
+
+# Depends on gles2 enabled and that's not default configuration
+EXCLUDE_FROM_WORLD = "1"
+
+SRC_URI = "git://github.com/smk-embedded/qt5-opengles2-test.git"
+SRCREV = "938390507054ed1258345f70ed55770d2fe56176"
+S = "${WORKDIR}/git"
+
+inherit qmake5
diff --git a/external/meta-qt5/recipes-qt/examples/qt5everywheredemo_1.0.bb b/external/meta-qt5/recipes-qt/examples/qt5everywheredemo_1.0.bb
new file mode 100644
index 00000000..56034cc4
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5everywheredemo_1.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Qt5 everywhere demo"
+DESCRIPTION = "Quick tour of Qt 5.0, primarily focusing on its graphical capabilities."
+LICENSE = "BSD"
+HOMEPAGE = "https://qt.gitorious.org/qt-labs"
+LIC_FILES_CHKSUM = "file://qml/QtDemo/main.qml;endline=39;md5=7d80863906a4bc8ffca77fd869e335a9"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects qtsvg qtmultimedia"
+
+SRCREV = "35d72a2eba7456a2efc5eb8b77afbc00f69ba0ac"
+QT_GIT_PROJECT = "qt-labs"
+SRC_URI = "${QT_GIT}/qt5-everywhere-demo"
+
+S = "${WORKDIR}/git/QtDemo"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/QtDemo ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/qml ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
diff --git a/external/meta-qt5/recipes-qt/examples/qt5ledscreen_1.0.bb b/external/meta-qt5/recipes-qt/examples/qt5ledscreen_1.0.bb
new file mode 100644
index 00000000..e221941f
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5ledscreen_1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "QT5 LedScreen"
+DESCRIPTION = "This is LedScreen Qt5 QML component"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README.txt;md5=fe07f4a0be40fe88f8c7ceaca63a28b5"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/ledscreen_1.0.tgz"
+SRC_URI[md5sum] = "8fc482d5a8b16f43f022c9a282f305b8"
+SRC_URI[sha256sum] = "fa4759b70a5fa148a901a3f9a659f7bd2503d73774022012bded880dffa0d15c"
+
+S = "${WORKDIR}/ledscreen_1.0"
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ #install -m 0755 ${B}/QUItBattery ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/* ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
diff --git a/external/meta-qt5/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb b/external/meta-qt5/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb
new file mode 100644
index 00000000..54875f97
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "NMap Carousel application is demonstrating the normal mapping technique using Qt5"
+DESCRIPTION = "Normal mapping is used for making the icons appear 3D with lighting and shadows"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=44;endline=55;md5=3a9db934c393a0cf198cbe7e73ebec86"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/Qt5_NMap_CarouselDemo_1.0.tgz"
+SRC_URI[md5sum] = "c1b4568cdbb6b3af4ca10c5a90aa8128"
+SRC_URI[sha256sum] = "445da212074a10a432f4508d125814212bbe7a967bfa47b015b92dfac6bfd65f"
+
+S = "${WORKDIR}/Qt5_NMap_CarouselDemo_1.0"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/Qt5_NMap_CarouselDemo ${D}${datadir}/${P}
+ cp ${S}/Qt5_NMap_CarouselDemo.qml ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/content ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
diff --git a/external/meta-qt5/recipes-qt/examples/qt5nmapper/change-property-string.patch b/external/meta-qt5/recipes-qt/examples/qt5nmapper/change-property-string.patch
new file mode 100644
index 00000000..dae2fdcc
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5nmapper/change-property-string.patch
@@ -0,0 +1,26 @@
+qt5nmapper: Change property string to onTextString
+
+Upstream-Status: Pending
+
+diff --git a/content_org/Switch.qml b/content/Switch.qml
+index 08a2cba..a8b8b26 100644
+--- a/content_org/Switch.qml
++++ b/content/Switch.qml
+@@ -5,7 +5,7 @@ Item {
+
+ property alias text: textItem.text
+ property bool checked: false
+- property string onText: "On"
++ property string onTextString: "On"
+ property string offText: "Off"
+
+ QtObject {
+@@ -76,7 +76,7 @@ Item {
+ color: "#000000"
+ font.pixelSize: 18
+ font.bold: true
+- text: onText
++ text: onTextString
+ }
+ Text {
+ anchors.verticalCenter: parent.verticalCenter
diff --git a/external/meta-qt5/recipes-qt/examples/qt5nmapper_1.0.bb b/external/meta-qt5/recipes-qt/examples/qt5nmapper_1.0.bb
new file mode 100644
index 00000000..3c2bc1a9
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qt5nmapper_1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "QT5 NMapper application"
+DESCRIPTION = "NMapper application is demonstrating the normal mapping technique using Qt5"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=47;endline=58;md5=9fb5bf76d564bc53812e40b133ff40dc"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/Qt5_NMapper_1.0.tgz \
+ file://change-property-string.patch"
+SRC_URI[md5sum] = "dafc425280144d8e286788e75a0dba0f"
+SRC_URI[sha256sum] = "607fbf4c448f00d3c563f9ef8a582bcb6e8fe550e80b56bf8d9127a417faa53b"
+
+S = "${WORKDIR}/Qt5_NMapper_1.0"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/Qt5_NMapper ${D}${datadir}/${P}
+ cp ${S}/Qt5_NMapper.qml ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/content ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
+
diff --git a/external/meta-qt5/recipes-qt/examples/qtsmarthome_1.0.bb b/external/meta-qt5/recipes-qt/examples/qtsmarthome_1.0.bb
new file mode 100644
index 00000000..03f3c994
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/qtsmarthome_1.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Qt5 smarthome QML demo application"
+DESCRIPTION = "This is the Smarthome QML demo application. It shows some user interfaces for controlling an automated house"
+HOMEPAGE = "http://www.basyskom.com/news/143-demos-qt5-port.html"
+LICENSE = "LGPLv2.1+ & GFDL-1.2"
+LIC_FILES_CHKSUM = "file://COPYING.DOC;md5=ad1419ecc56e060eccf8184a87c4285f \
+ file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://share.basyskom.com/demos/smarthome_src.tar.gz"
+SRC_URI[md5sum] = "883b0376239baec20ebec072e938a995"
+SRC_URI[sha256sum] = "fceaa813c33e462bad6c0383eaef81a6f6e586c15d1fa73898173b517fc1cda6"
+
+S = "${WORKDIR}/smarthome_src"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/smarthome ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/qml ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/components ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
diff --git a/external/meta-qt5/recipes-qt/examples/quitbattery_1.0.0.bb b/external/meta-qt5/recipes-qt/examples/quitbattery_1.0.0.bb
new file mode 100644
index 00000000..7593ab29
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/quitbattery_1.0.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "QT5 QUItBattery"
+DESCRIPTION = "This package contains QUItBatteryComponent with few usage examples"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=37;endline=46;md5=6df4bcb7f9092d42a84f32eacb61bdc4"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/QUItBattery_1.0.0.tar.gz"
+SRC_URI[md5sum] = "7c7babc1086491b116b01d154b6163fd"
+SRC_URI[sha256sum] = "38dcb7630553c397f9d8a53c6411b1a6237956ed8dd4859e01487b1dd8f37873"
+
+S = "${WORKDIR}/QUItBattery_1.0.0"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/QUItBattery ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/qml ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"
diff --git a/external/meta-qt5/recipes-qt/examples/quitindicators_1.0.1.bb b/external/meta-qt5/recipes-qt/examples/quitindicators_1.0.1.bb
new file mode 100644
index 00000000..bc370f44
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/examples/quitindicators_1.0.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "QUItIndicators components with few usage examples"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=38;endline=45;md5=9a4a88358260db32391eda6ebe7562e5"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/QUItIndicators_1.0.1.tar.gz"
+SRC_URI[md5sum] = "85ec60b553e181c55b331a9921d1b9a0"
+SRC_URI[sha256sum] = "db84112adbde9b6f28c129e8fb37a6912f4bc34bed18e57f570fb78ea0cb6ae2"
+
+S = "${WORKDIR}/QUItIndicators_1.0.1"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/QUItIndicators ${D}${datadir}/${P}
+ cp -R --no-dereference --preserve=mode,links ${S}/qml ${D}${datadir}/${P}
+}
+
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"