summaryrefslogtreecommitdiffstats
path: root/external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb')
-rw-r--r--external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb b/external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
new file mode 100644
index 00000000..1f29dcfe
--- /dev/null
+++ b/external/meta-qt5/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "This driver extends Qt's platform support (QPA) for Virtualbox guests. \
+It uses the integrated pointer feature to create a smooth conversion from \
+the host pointer to touchscreen events in the guest, without grabbing the \
+host pointer."
+SUMMARY = "Touchscreen driver for integrated mouse pointer in VirtualBox"
+LICENSE = "LGPL-2.1 & GPL-3.0"
+LIC_FILES_CHKSUM = " \
+ file://vboxtouch.cpp;beginline=1;endline=22;md5=ca51db8f7c0606c77f702dcee4cf31d9 \
+ file://evdevmousehandler.cpp;beginline=1;endline=40;md5=9081062f6e7f74b6e62ad7ecee4a71be \
+"
+
+PV = "1.1.4+gitr${SRCPV}"
+
+DEPENDS = "qtbase"
+
+# Needed with gcc-5.2 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65801
+CXXFLAGS += "-Wno-narrowing"
+
+SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git"
+SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb"
+S = "${WORKDIR}/git/vboxtouch"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/generic/libvboxtouchplugin.so"
+FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/cmake/*"
+
+SRC_URI += "file://0001-VirtualboxTouchScreenHandler-initialize-m_mouse.patch;patchdir=.."