summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
new file mode 100644
index 00000000..0038ea00
--- /dev/null
+++ b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0001-add-the-default-cmake-cxx-flag-for-oe.patch
@@ -0,0 +1,53 @@
+From acc1b869e52e1c2e7dba0b534bca34a1e7da8404 Mon Sep 17 00:00:00 2001
+From: Phong Tran <tranmanphong@gmail.com>
+Date: Tue, 19 Jul 2016 07:16:24 +0700
+Subject: [PATCH 01/10] add the default cmake cxx flag for oe
+
+Signed-off-by: Phong Tran <tranmanphong@gmail.com>
+
+%% original patch: 0001-add-the-default-cmake-cxx-flag-for-oe.patch
+---
+ CMakeLists.txt | 6 +++---
+ src/components/functional_module/CMakeLists.txt | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 450a919..f1dc97a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -75,8 +75,8 @@ set(POLICY_OPTION "$ENV{POLICY_TYPE}")
+ set(SECURITY_OPTION "$ENV{SECURITY_MODE}")
+ set(COMPONENTS_DIR ${CMAKE_SOURCE_DIR}/src/components)
+ set(SNAPSHOT_TAG "$ENV{SNAPSHOT_TAG}")
+-set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
+-set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
++#set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
++#set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
+ set(BUILDDIR "$ENV{BUILDDIR}")
+
+ if (ARCH_TYPE_OPTION)
+@@ -192,7 +192,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+ set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
+ set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
+
+-set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
+
+ if (USE_GOLD_LD)
+ execute_process(COMMAND ld -v OUTPUT_VARIABLE result)
+diff --git a/src/components/functional_module/CMakeLists.txt b/src/components/functional_module/CMakeLists.txt
+index 07db91f..f5b89e0 100644
+--- a/src/components/functional_module/CMakeLists.txt
++++ b/src/components/functional_module/CMakeLists.txt
+@@ -4,7 +4,7 @@ else()
+ set(GCOV_FLAGS "")
+ endif()
+
+-set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wno-deprecated-declarations -Wall -Werror ${GCOV_FLAGS}")
+
+ if (CMAKE_BUILD_TYPE)
+ if (${CMAKE_BUILD_TYPE} STREQUAL "Release")
+--
+2.7.4
+