summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
new file mode 100644
index 00000000..6384ae1c
--- /dev/null
+++ b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0002-Use-the-default-install-prefix-of-cmake.patch
@@ -0,0 +1,32 @@
+From 91d7636467b6bb73ed843c16c35da63455872446 Mon Sep 17 00:00:00 2001
+From: Phong Tran <tranmanphong@gmail.com>
+Date: Sun, 17 Jul 2016 08:41:03 +0700
+Subject: [PATCH 02/10] Use the default install prefix of cmake
+
+It's better to use the oe cmake install prefix instead of
+the current value. This is for avoiding the wrong
+installation path while do_install().
+
+Signed-off-by: Phong Tran <tranmanphong@gmail.com>
+
+%% original patch: 0002-Use-the-default-install-prefix-of-cmake.patch
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f1dc97a..732b601 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -189,7 +189,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+
+ # Please do not change compiler/linker flags if You do not know how particular
+ # flag is handled by CMake
+-set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
++# set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
+ set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -std=gnu++0x -Wall -Werror -Wno-deprecated-declarations -Wuninitialized -Wvla")
+--
+2.7.4
+