summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb b/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
new file mode 100644
index 00000000..bac1740e
--- /dev/null
+++ b/external/meta-sdl/recipes-automotive/sdl-generic-hmi/sdl-generic-hmi_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "HTML based reference HMI for SmartDeviceLink"
+DESCRIPTION = "SmartDeviceLink (SDL) is a standard set of protocols and \
+messages that connect applications on a smartphone to a vehicle head \
+unit."
+HOMEPAGE = "https://www.smartdevicelink.com"
+SECTION = "app"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf455e8d39d2ded1d85b1c5dea6ec3c5"
+
+SRC_URI = "git://github.com/smartdevicelink/generic_hmi.git;branch=develop"
+
+PV = "0.0.0+git${SRCPV}"
+SRCREV = "8d05d53d228d1dec82b78af824e33a0de5697e0c"
+
+S = "${WORKDIR}/git"
+
+PACKAGES = " \
+ ${PN} \
+"
+
+FILES_${PN}_append = " \
+ ${datadir}/smartdevicelink/generic_hmi/ \
+"
+
+do_install() {
+ install -d ${D}${datadir}/smartdevicelink/generic_hmi
+ install -m 0644 ${S}/index.html ${D}${datadir}/smartdevicelink/generic_hmi/
+ install -d ${D}${datadir}/smartdevicelink/generic_hmi/build
+ install -m 0644 ${S}/build/* ${D}${datadir}/smartdevicelink/generic_hmi/build
+ install -d ${D}${datadir}/smartdevicelink/generic_hmi/fonts
+ install -m 0644 ${S}/fonts/* ${D}${datadir}/smartdevicelink/generic_hmi/fonts
+}
+