summaryrefslogtreecommitdiffstats
path: root/external/meta-security/recipes-security/checksec/checksec_1.5.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-security/recipes-security/checksec/checksec_1.5.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-security/recipes-security/checksec/checksec_1.5.bb')
-rw-r--r--external/meta-security/recipes-security/checksec/checksec_1.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-security/recipes-security/checksec/checksec_1.5.bb b/external/meta-security/recipes-security/checksec/checksec_1.5.bb
new file mode 100644
index 00000000..07f0f7c7
--- /dev/null
+++ b/external/meta-security/recipes-security/checksec/checksec_1.5.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Program radominization"
+DESCRIPTION = "The checksec.sh script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD"
+HOMEPAGE="http://www.trapkit.de/tools/checksec.html"
+
+LIC_FILES_CHKSUM = "file://checksec.sh;md5=075996be339ab16ad7b94d6de3ee07bd"
+
+SRC_URI = "file://checksec.sh"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/checksec.sh ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "bash"