summaryrefslogtreecommitdiffstats
path: root/external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb')
-rw-r--r--external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb b/external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb
new file mode 100644
index 00000000..b9ba7c6a
--- /dev/null
+++ b/external/meta-spdxscanner/recipes-devtools/python/python-whatthepatch_0.0.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A patch parsing library"
+DESCRIPTION = "What The Patch!? is a library for parsing patch files. \
+Its only purpose is to read a patch file and get it into some usable form by other programs."
+HOMEPAGE = "https://pypi.python.org/pypi/whatthepatch"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://setup.py;md5=a6377e466f612f442bbc6bb2e91eee5d"
+
+SRC_URI = "https://pypi.python.org/packages/64/1e/7a63cba8a0d70245b9ab1c03694dabe36476fa65ee546e6dff6c8660434c/whatthepatch-0.0.5.tar.gz \
+ "
+
+SRC_URI[md5sum] = "80d7c24de99ca9501f07b42e88d6f7c1"
+SRC_URI[sha256sum] = "494a2ec6c05b80f9ed1bd773f5ac9411298e1af6f0385f179840b5d60d001aa6"
+
+S="${WORKDIR}/whatthepatch-0.0.5"
+PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'pythonnative', '', d)}"
+PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}"
+
+inherit distutils ${PYTHON_INHERIT} setuptools python-dir
+
+BBCLASSEXTEND = "native"