summaryrefslogtreecommitdiffstats
path: root/external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb')
-rw-r--r--external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb b/external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb
new file mode 100644
index 00000000..c93e86d8
--- /dev/null
+++ b/external/meta-spdxscanner/recipes-devtools/python/python3-lid_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Identify OS licenses and OS license text in source code."
+HOMEPAGE = "https://source.codeaurora.org/external/qostg/lid/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3dd6f349067c9c1c473ae3f54efeb2e0"
+
+SRC_URI = "git://source.codeaurora.org/external/qostg/lid;protocol=https \
+ "
+
+S = "${WORKDIR}/git"
+
+SRCREV = "d4ec360b51f34e8e73dcad7b0539fc0029eb7a20"
+BRANCH = "master"
+PV = "0.16.1"
+
+inherit distutils pythonnative setuptools python-dir
+
+DEPENDS += "python-pyyaml-native \
+ python-future-native \
+ python-nltk-native \
+ python-six-native \
+ python-chardet-native \
+ "
+
+BBCLASSEXTEND = "native"