summaryrefslogtreecommitdiffstats
path: root/external/meta-updater-qemux86-64
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /external/meta-updater-qemux86-64
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'external/meta-updater-qemux86-64')
-rw-r--r--external/meta-updater-qemux86-64/.gitlab-ci.yml68
-rw-r--r--external/meta-updater-qemux86-64/README.md5
-rw-r--r--external/meta-updater-qemux86-64/conf/layer.conf2
-rw-r--r--external/meta-updater-qemux86-64/recipes-bsp/u-boot/u-boot_%.bbappend4
4 files changed, 76 insertions, 3 deletions
diff --git a/external/meta-updater-qemux86-64/.gitlab-ci.yml b/external/meta-updater-qemux86-64/.gitlab-ci.yml
new file mode 100644
index 00000000..7aa2d2b1
--- /dev/null
+++ b/external/meta-updater-qemux86-64/.gitlab-ci.yml
@@ -0,0 +1,68 @@
+stages:
+ - docker
+ - checkout
+ - test
+ - trigger
+
+variables:
+ BITBAKE_IMAGE: ${METAUPDATER_REGISTRY_IMAGE}:ci-master-bitbake
+ BITBAKE_CHECKOUT_IMAGE: ${METAUPDATER_REGISTRY_IMAGE}:ci-master-checkout
+
+include:
+ - project: 'olp/edge/ota/connect/client/meta-updater'
+ ref: 'master'
+ file: 'scripts/ci/gitlab/docker.yml'
+ - project: 'olp/edge/ota/connect/client/meta-updater'
+ ref: 'master'
+ file: 'scripts/ci/gitlab/checkout.yml'
+ - project: 'olp/edge/ota/connect/client/meta-updater'
+ ref: 'master'
+ file: 'scripts/ci/gitlab/tests.yml'
+
+Docker setup:
+ extends: .bb_docker_remote
+
+ stage: docker
+ except:
+ - pushes
+
+Checkout:
+ extends: .bb_checkout
+
+ stage: checkout
+ variables:
+ MANIFEST: thud
+ CURRENT_PROJECT: meta-updater-qemux86-64
+ except:
+ - pushes
+
+Build core-image-minimal (qemu):
+ extends: .bitbake
+
+ stage: test
+ variables:
+ TEST_BUILD_DIR: 'build-core-image-minimal-qemux86_64'
+ BITBAKE_TARGETS: 'core-image-minimal'
+ except:
+ - pushes
+
+Oe-selftest qemux86_64:
+ extends: .oe-selftest
+
+ stage: test
+ variables:
+ TEST_BUILD_DIR: 'build-oe-qemux86_64'
+ OE_SELFTESTS: 'updater_native updater_qemux86_64'
+ except:
+ - pushes
+
+# -- otf
+
+trigger-otf-on-pr:
+ stage: trigger
+ when: always
+ except:
+ - pushes
+ script:
+ - apk add --no-cache curl
+ - curl -X POST -F "token=$CI_JOB_TOKEN" -F "ref=master" -F "variables[BITBAKE_JOB_ONLY]=true" -F "variables[BITBAKE_ENV]=thud" -F "variables[PROJECT_NAME]=meta-updater-qemux86-64" -F "variables[PROJECT_SHA]=$CI_COMMIT_SHA" https://main.gitlab.in.here.com/api/v4/projects/163/trigger/pipeline
diff --git a/external/meta-updater-qemux86-64/README.md b/external/meta-updater-qemux86-64/README.md
index 95ffe0ca..4aa25d05 100644
--- a/external/meta-updater-qemux86-64/README.md
+++ b/external/meta-updater-qemux86-64/README.md
@@ -1,3 +1,6 @@
-# BSP layer for testing OSTree with QEMU on x86_64 host
+# BSP layer for updating QEMU x86-64 guests with OSTree
OSTree bootloader integration for qemu-x86-64. Add it to BBLAYERS when using [meta-updater](https://github.com/advancedtelematic/meta-updater) with [QEMU](https://www.qemu.org).
+
+For more documentation on using this layer and [HERE OTA Connect](https://connect.ota.here.com/), please see the [OTA Connect documentation portal](https://docs.ota.here.com/), in particular the guide on [building a QEMU image](https://docs.ota.here.com/ota-client/latest/build-qemu.html).
+
diff --git a/external/meta-updater-qemux86-64/conf/layer.conf b/external/meta-updater-qemux86-64/conf/layer.conf
index 8920f552..91249fa3 100644
--- a/external/meta-updater-qemux86-64/conf/layer.conf
+++ b/external/meta-updater-qemux86-64/conf/layer.conf
@@ -8,4 +8,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "updater-qemux86-64"
BBFILE_PATTERN_updater-qemux86-64 = "^${LAYERDIR}/"
BBFILE_PRIORITY_updater-qemux86-64 = "7"
+
+LAYERDEPENDS_updater-qemux86-64 = "sota"
LAYERSERIES_COMPAT_updater-qemux86-64 = "thud"
diff --git a/external/meta-updater-qemux86-64/recipes-bsp/u-boot/u-boot_%.bbappend b/external/meta-updater-qemux86-64/recipes-bsp/u-boot/u-boot_%.bbappend
index 677f8683..74fa95a9 100644
--- a/external/meta-updater-qemux86-64/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/external/meta-updater-qemux86-64/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -9,7 +9,7 @@ SRC_URI +=" \
# fix after default security flags in poky
TOOLCHAIN_OPTIONS_append = "${SECURITY_NOPIE_CFLAGS}"
-do_compile_prepend() {
+do_compile_prepend_qemux86-64 () {
export BUILD_ROM=y
}
-UBOOT_SUFFIX = "rom"
+UBOOT_SUFFIX_qemux86-64 = "rom"