summaryrefslogtreecommitdiffstats
path: root/external/meta-updater-raspberrypi/recipes-bsp/bootfiles
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-updater-raspberrypi/recipes-bsp/bootfiles
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-updater-raspberrypi/recipes-bsp/bootfiles')
-rw-r--r--external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bootfiles.bbappend (renamed from external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend)0
-rw-r--r--external/meta-updater-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend13
2 files changed, 7 insertions, 6 deletions
diff --git a/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bootfiles.bbappend
index adb19c09..adb19c09 100644
--- a/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ b/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/bootfiles.bbappend
diff --git a/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 5073560f..6ade9f3d 100644
--- a/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/external/meta-updater-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -2,16 +2,17 @@ DISABLE_OVERSCAN = "1"
do_deploy_append() {
if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_LWM}" ]; then
- sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
fi
if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_HWM}" ]; then
- sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
fi
- echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "avoid_warnings=2" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+ echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+ echo "dtparam=audio=on" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
}
-ENABLE_UART_raspberrypi3 = "1"
+ENABLE_UART_raspberrypi3 ?= "1"
+ENABLE_UART_raspberrypi4 ?= "1"