summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb')
-rw-r--r--external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb b/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
new file mode 100644
index 00000000..d840a951
--- /dev/null
+++ b/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Sample network configuration for an Uptane Primary"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+inherit allarch
+
+SRC_URI = "\
+ file://27-dhcp-client-external.network \
+ "
+
+FILES_${PN} = "/usr/lib/systemd/network"
+
+PR = "1"
+
+do_install() {
+ install -d ${D}/usr/lib/systemd/network
+ install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
+}
+
+PRIMARY_IP ?= "10.0.3.1"
+
+IP_ADDR = "${PRIMARY_IP}"
+CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
+
+require network-config.inc
+
+# vim:set ts=4 sw=4 sts=4 expandtab: