summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-containers/crun/crun_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-virtualization/recipes-containers/crun/crun_git.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-virtualization/recipes-containers/crun/crun_git.bb')
-rw-r--r--external/meta-virtualization/recipes-containers/crun/crun_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-containers/crun/crun_git.bb b/external/meta-virtualization/recipes-containers/crun/crun_git.bb
new file mode 100644
index 00000000..7781e110
--- /dev/null
+++ b/external/meta-virtualization/recipes-containers/crun/crun_git.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A fast and low-memory footprint OCI Container Runtime fully written in C."
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+PRIORITY = "optional"
+
+SRCREV_crun = "a43f72196f7aaf713dc997eaddd0f08612f60ac0"
+SRCREV_libocispec = "01c8f977ff5ed1e8010f40c2572343be1a70a51b"
+SRCREV_ispec = "775207bd45b6cb8153ce218cc59351799217451f"
+SRCREV_rspec = "19e92ca817772b4466f2ed2b8d808dfb7a8ab4be"
+
+SRCREV_FORMAT = "crun_rspec"
+SRC_URI = "git://github.com/containers/crun.git;branch=master;name=crun \
+ git://github.com/containers/libocispec.git;branch=master;name=libocispec;destsuffix=git/libocispec \
+ git://github.com/opencontainers/runtime-spec.git;branch=master;name=rspec;destsuffix=git/libocispec/runtime-spec \
+ git://github.com/opencontainers/image-spec.git;branch=master;name=ispec;destsuffix=git/libocispec/image-spec \
+ "
+
+PV = "0.10.2+git${SRCREV_crun}"
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig
+
+PACKAGECONFIG ??= ""
+
+DEPENDS = "yajl libcap go-md2man-native"
+# TODO: is there a packageconfig to turn this off ?
+DEPENDS += "libseccomp"
+DEPENDS += "oci-image-spec oci-runtime-spec"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}