summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb')
-rw-r--r--external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb b/external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb
new file mode 100644
index 00000000..8de0bfcf
--- /dev/null
+++ b/external/meta-virtualization/recipes-core/kata-containers/kata-proxy_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = " Kata Containers stdio proxy component"
+HOMEPAGE = "https://github.com/kata-containers/proxy"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/proxy/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+GO_IMPORT = "github.com/kata-containers/proxy"
+SRCREV = "1148847739f9a9f47b92e34e4f309dc109d4dba9"
+SRC_URI = "git://${GO_IMPORT}.git \
+ "
+
+RDEPENDS_${PN}-dev_append = "bash"
+
+S = "${WORKDIR}/git"
+
+inherit go
+
+do_compile() {
+ # Pass the needed cflags/ldflags so that cgo
+ # can find the needed headers files and libraries
+ export GOARCH=${TARGET_GOARCH}
+ export CGO_ENABLED="1"
+ export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
+ export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
+
+ cd ${S}/src/${GO_IMPORT}
+ oe_runmake kata-proxy
+}
+
+do_install() {
+ mkdir -p ${D}/${libexecdir}/kata-containers
+ cp ${WORKDIR}/git/src/${GO_IMPORT}/kata-proxy ${D}/${libexecdir}/kata-containers
+}
+
+deltask compile_ptest_base