summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb')
-rw-r--r--external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb b/external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb
new file mode 100644
index 00000000..3c64f24e
--- /dev/null
+++ b/external/meta-virtualization/recipes-extended/hyperstart/hyperstart_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The tiny Init service for HyperContainer"
+DESCRIPTION = "The init Task for HyperContainer"
+
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools-brokensep
+
+SRC_URI = "git://github.com/hyperhq/hyperstart.git"
+SRC_URI += "file://0001-container.c-Fix-compiler-errors-that-gcc-8.1.0-repor.patch"
+
+SRCREV = "15bb718ad34045aa1962a8204f602c6afe9a76ab"
+PV = "v0.2+git${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+CACHED_CONFIGUREVARS = "ac_cv_file__usr_include_linux_vm_sockets_h=true"
+
+do_install() {
+ install -d ${D}/var/lib/hyper/
+
+ install -m644 ${S}/build/hyper-initrd.img ${D}/var/lib/hyper/
+ install -m644 ${S}/build/arch/x86_64/kernel ${D}/var/lib/hyper/
+}
+
+FILES_${PN} += "/var/lib/hyper"