summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb')
-rw-r--r--external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb b/external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb
new file mode 100644
index 00000000..d487ee27
--- /dev/null
+++ b/external/meta-virtualization/recipes-extended/kvmtool/kvmtool.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Native Linux KVM tool"
+DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
+
+DEPENDS = "dtc libaio zlib"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+inherit kernel-arch
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \
+ file://external-crosscompiler.patch \
+ file://0001-Avoid-pointers-for-address-of-packed-members.patch \
+ file://0001-kvmtool-9p-fixed-compilation-error.patch \
+ file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \
+ "
+
+SRCREV = "0e1882a49f81cb15d328ef83a78849c0ea26eecc"
+PV = "4.14.0+git${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE='V=1 EXTRA_CFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated -I${STAGING_KERNEL_BUILDDIR}/arch/${ARCH}/include/generated"'
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/lkvm ${D}${bindir}/
+}