summaryrefslogtreecommitdiffstats
path: root/external/poky/meta-skeleton/conf
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta-skeleton/conf
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta-skeleton/conf')
-rw-r--r--external/poky/meta-skeleton/conf/layer.conf17
-rw-r--r--external/poky/meta-skeleton/conf/multilib-example.conf13
-rw-r--r--external/poky/meta-skeleton/conf/multilib-example2.conf13
3 files changed, 43 insertions, 0 deletions
diff --git a/external/poky/meta-skeleton/conf/layer.conf b/external/poky/meta-skeleton/conf/layer.conf
new file mode 100644
index 00000000..13bda7b5
--- /dev/null
+++ b/external/poky/meta-skeleton/conf/layer.conf
@@ -0,0 +1,17 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "skeleton"
+BBFILE_PATTERN_skeleton = "^${LAYERDIR}/"
+BBFILE_PRIORITY_skeleton = "1"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_skeleton = "1"
+
+LAYERDEPENDS_skeleton = "core"
+
+LAYERSERIES_COMPAT_skeleton = "thud"
diff --git a/external/poky/meta-skeleton/conf/multilib-example.conf b/external/poky/meta-skeleton/conf/multilib-example.conf
new file mode 100644
index 00000000..da6da7f1
--- /dev/null
+++ b/external/poky/meta-skeleton/conf/multilib-example.conf
@@ -0,0 +1,13 @@
+#
+# Sample multilib configuration which the user can either add in local.conf
+# or specific in an configuration file like this, then require it.
+#
+# This configuration specifies an x86 64 bit machine as the main machine
+# type and then adds a multilib in the "lib32" directory where those
+# libraries are compiled with the "x86" tune.
+#
+
+MACHINE = "qemux86-64"
+require conf/multilib.conf
+MULTILIBS = "multilib:lib32"
+DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
diff --git a/external/poky/meta-skeleton/conf/multilib-example2.conf b/external/poky/meta-skeleton/conf/multilib-example2.conf
new file mode 100644
index 00000000..2596f61d
--- /dev/null
+++ b/external/poky/meta-skeleton/conf/multilib-example2.conf
@@ -0,0 +1,13 @@
+#
+# Sample multilib configuration which the user can either add in local.conf
+# or specific in an configuration file like this, then require it.
+#
+# This configuration specifies an x86 64 bit machine as the main machine
+# type and then adds a multilib in the "libx32" directory where those
+# libraries are compiled with the "x86-64-x32" tune.
+#
+
+MACHINE = "qemux86-64"
+require conf/multilib.conf
+MULTILIBS = "multilib:libx32"
+DEFAULTTUNE_virtclass-multilib-libx32 = "x86-64-x32"