summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb')
-rw-r--r--external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb b/external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb
new file mode 100644
index 00000000..53cf1cf7
--- /dev/null
+++ b/external/poky/meta/recipes-bsp/formfactor/formfactor_0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Device formfactor information"
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r45"
+
+SRC_URI = "file://config file://machconfig"
+S = "${WORKDIR}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_install() {
+ # Install file only if it has contents
+ install -d ${D}${sysconfdir}/formfactor/
+ install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
+ if [ -s "${S}/machconfig" ]; then
+ install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
+ fi
+}