summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb')
-rw-r--r--external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb b/external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
index 7ae7969f..29ec5ec2 100644
--- a/external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
+++ b/external/poky/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
@@ -9,8 +9,13 @@ S = "${WORKDIR}"
do_install() {
install -m 0755 ${WORKDIR}/init-boot.sh ${D}/init
+
+ # Create device nodes expected by some kernels in initramfs
+ # before even executing /init.
+ install -d ${D}/dev
+ mknod -m 622 ${D}/dev/console c 5 1
}
inherit allarch
-FILES_${PN} += " /init "
+FILES_${PN} += "/init /dev/console"