summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb')
-rw-r--r--external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb b/external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
new file mode 100644
index 00000000..465aa965
--- /dev/null
+++ b/external/poky/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Extended cryptographic library (from glibc)"
+DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
+HOMEPAGE = "https://github.com/besser82/libxcrypt"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM ?= "file://LICENSING;md5=cb3ca4cabd2447a37bf186fad6f79852 \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit autotools pkgconfig
+
+SRCREV ?= "21b455b68baad279e6a3936faced16c5e5634376"
+SRCBRANCH ?= "develop"
+
+SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
+ "
+
+PROVIDES = "virtual/crypt"
+
+FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
+
+S = "${WORKDIR}/git"
+
+BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
+
+BBCLASSEXTEND = "nativesdk"