summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb')
-rw-r--r--external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb b/external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb
new file mode 100644
index 00000000..ecff2faf
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/intltool/intltool_0.51.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Utility scripts for internationalizing XML"
+SECTION = "devel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \
+ file://intltool-nowarn.patch \
+ file://perl-522-deprecations.patch \
+ file://remove-perl-check.patch \
+ file://noperlcheck.patch \
+ "
+SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63"
+SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"
+
+UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
+
+DEPENDS = "libxml-parser-perl-native"
+RDEPENDS_${PN} = "gettext-dev libxml-parser-perl"
+DEPENDS_class-native = "libxml-parser-perl-native gettext-native"
+
+inherit autotools pkgconfig perlnative
+
+export PERL = "${bindir}/env perl"
+PERL_class-native = "/usr/bin/env nativeperl"
+PERL_class-nativesdk = "/usr/bin/env perl"
+
+# gettext is assumed to exist on the host
+RDEPENDS_${PN}_class-native = "libxml-parser-perl-native"
+RRECOMMENDS_${PN} = "perl-modules"
+RRECOMMENDS_${PN}_class-native = ""
+
+FILES_${PN}-dev = ""
+FILES_${PN} += "${datadir}/aclocal"
+
+INSANE_SKIP_${PN} += "dev-deps"
+
+BBCLASSEXTEND = "native nativesdk"