summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb')
-rw-r--r--external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb b/external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb
new file mode 100644
index 00000000..4eba9ecd
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/python/python3-iniparse_0.4.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Accessing and Modifying INI files"
+HOMEPAGE = "https://pypi.python.org/pypi/iniparse/"
+LICENSE = "MIT & PSF"
+LIC_FILES_CHKSUM = "file://LICENSE-PSF;md5=1c78a5bb3584b353496d5f6f34edb4b2 \
+ file://LICENSE;md5=52f28065af11d69382693b45b5a8eb54"
+
+SRC_URI = "file://0001-Add-python-3-compatibility.patch "
+
+SRC_URI[md5sum] = "5e573e9e9733d97623881ce9bbe5eca6"
+SRC_URI[sha256sum] = "abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054"
+
+inherit pypi distutils3
+
+RDEPENDS_${PN} += "python3-core python3-six"
+DEPENDS += "python3-six"
+
+BBCLASSEXTEND = "native nativesdk"