summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb')
-rw-r--r--external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb b/external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
new file mode 100644
index 00000000..c55577c6
--- /dev/null
+++ b/external/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
@@ -0,0 +1,13 @@
+require cryptodev.inc
+
+SUMMARY = "A /dev/crypto device driver header file"
+
+do_compile[noexec] = "1"
+
+# Just install cryptodev.h which is the only header file needed to be exported
+do_install() {
+ install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
+}
+
+ALLOW_EMPTY_${PN} = "1"
+BBCLASSEXTEND = "native nativesdk"