summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb')
-rw-r--r--external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
new file mode 100644
index 00000000..c986eb8b
--- /dev/null
+++ b/external/poky/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -0,0 +1,32 @@
+KBRANCH ?= "v4.18/standard/tiny/base"
+KBRANCH_qemuarm ?= "v4.18/standard/tiny/arm-versatile-926ejs"
+
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.18.33"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine_qemuarm ?= "bc69d96021b7407a636cb7bc56334bf95a525e76"
+SRCREV_machine ?= "1a564c76f41cff5c9e9011c4dbb5ef8453836b5d"
+SRCREV_meta ?= "865683fc87deee7030cd168f295e8afd70894d6c"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"