summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb b/external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb
index 6ee3e1c0..1c9f2aed 100644
--- a/external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/external/poky/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -51,10 +51,13 @@ do_install_append () {
rm ${D}${libexecdir}/${PN}/stap-env
fi
- # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
- install -d `dirname ${D}${systemd_unitdir}`
- mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
- rmdir ${D}${prefix}/lib --ignore-fail-on-non-empty
+ if [ ${D}${prefix}/lib != `dirname ${D}${systemd_unitdir}` ]; then
+ # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
+ # without usrmerge distro feature enabled
+ install -d `dirname ${D}${systemd_unitdir}`
+ mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
+ rmdir ${D}${prefix}/lib --ignore-fail-on-non-empty
+ fi
# Ensure correct ownership for files copied in
chown root:root ${D}${sysconfdir}/stap-exporter/* -R