summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb')
-rw-r--r--external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb b/external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb
new file mode 100644
index 00000000..0f7f0916
--- /dev/null
+++ b/external/poky/meta/recipes-rt/images/core-image-rt-sdk.bb
@@ -0,0 +1,20 @@
+require recipes-core/images/core-image-minimal.bb
+
+# Skip processing of this recipe if linux-yocto-rt is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers.
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
+ raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
+}
+
+DESCRIPTION = "Small image capable of booting a device with a test suite and \
+tools for real-time use. It includes the full meta-toolchain, development \
+headers and libraries to form a standalone SDK."
+DEPENDS = "linux-yocto-rt"
+
+IMAGE_FEATURES += "dev-pkgs tools-sdk tools-debug eclipse-debug tools-profile tools-testapps debug-tweaks"
+
+IMAGE_INSTALL += "rt-tests hwlatdetect kernel-dev"
+
+LICENSE = "MIT"