summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb')
-rw-r--r--external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb b/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
new file mode 100644
index 00000000..94f96e62
--- /dev/null
+++ b/external/poky/meta/recipes-support/boost/bjam-native_1.68.0.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}