summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb')
-rw-r--r--external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb b/external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb
new file mode 100644
index 00000000..43f76dc5
--- /dev/null
+++ b/external/poky/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.10.bb
@@ -0,0 +1,29 @@
+require libcap-ng.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
+
+SUMMARY .= " - python"
+
+inherit lib_package autotools python3native
+
+DEPENDS += "libcap-ng python3 swig-native"
+
+S = "${WORKDIR}/libcap-ng-${PV}"
+
+EXTRA_OECONF += "--with-python --with-python3"
+EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
+
+do_install_append() {
+ rm -rf ${D}${bindir}
+ rm -rf ${D}${libdir}/.debug
+ rm -f ${D}${libdir}/lib*
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${datadir}
+ rm -rf ${D}${includedir}
+}
+
+# PACKAGES = "${PN}"
+
+FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
+FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
+