summaryrefslogtreecommitdiffstats
path: root/meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb')
-rw-r--r--meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb b/meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
new file mode 100644
index 00000000..10728d56
--- /dev/null
+++ b/meta-agl-cluster-demo/recipes-demo-hmi/cluster-receiver/qt-cluster-receiver_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Instrument Cluster Receiver AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "wayland wayland-native \
+ qtwayland qtwayland-native \
+ qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
+
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+"