summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/homescreen
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-demo/recipes-demo-hmi/homescreen
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/homescreen')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb b/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
new file mode 100644
index 00000000..984e5153
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application build with recipe method"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ agl-service-homescreen \
+ agl-service-windowmanager \
+ agl-service-weather \
+ libqtappfw \
+ qlibwindowmanager \
+ libhomescreen \
+ libafb-helpers-qt \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"