summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb b/meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
new file mode 100644
index 00000000..ce8a1d11
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Launcher Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-launcher/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}