summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb b/meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb
new file mode 100644
index 00000000..8c3f72f6
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/launcher/launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibwindowmanager \
+ qlibhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"