summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb b/meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb
new file mode 100644
index 00000000..553cc8ac
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/phone/phone_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Phone for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating phone on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+ libqtappfw \
+ libhomescreen \
+ qlibwindowmanager \
+ gstreamer1.0 \
+"
+
+inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap"