summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb b/meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb
new file mode 100644
index 00000000..84a43a86
--- /dev/null
+++ b/meta-agl-demo/recipes-demo-hmi/windowmanager/windowmanager_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "AGL WindowManager Application"
+DESCRIPTION = "WindowManager"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+S = "${WORKDIR}/git/"
+
+inherit qmake5 systemd
+DEPENDS = " qtbase "
+
+# for WindowManager:
+DEPENDS += " wayland-ivi-extension "
+
+LIC_FILES_CHKSUM = "file://windowmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "eeedc5e9e67917bd3346dbe5332e667757a3b28d"
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/windowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+do_install() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${B}/windowmanager/WindowManager ${D}/usr/AGL/${PN}/
+
+ install -d ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/windowmanager/conf/WindowManager.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/windowmanager/conf/WindowManager.path ${D}${systemd_user_unitdir}
+
+ install -d ${D}${sysconfdir}/systemd/user/default.target.wants
+ ln -sf ${systemd_user_unitdir}/WindowManager.path ${D}${sysconfdir}/systemd/user/default.target.wants
+}
+
+FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
+FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
+