summaryrefslogtreecommitdiffstats
path: root/meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb')
-rwxr-xr-xmeta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb b/meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb
new file mode 100755
index 00000000..cd52b68a
--- /dev/null
+++ b/meta-agl-devel/meta-audio-soundmanager-framework/recipes-multimedia/module-router/module-router_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Pulseaudio router module"
+HOMEPAGE = "https://github.com/tisogai/module-router"
+LICENSE = "LGPLv2"
+SECTION = "multimedia"
+DEPENDS = "pulseaudio"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
+
+SRC_URI = " \
+ git://github.com/tisogai/module-router.git;protocol=https;branch=master \
+ "
+
+SRCREV = "8104a3174e6f54ace53066ab1797d9b9bd2bdf63"
+
+S = "${WORKDIR}/git"
+inherit cmake
+OECMAKE_CXX_FLAGS += "-std=c++11"
+
+# NOTE: The specific product should have a separate customtypes.xsd
+# and should be appended to FILES_${PN} in product specific
+# audiomanager-generic-controller_git.bbappend
+FILES_${PN} = " \
+ ${libdir}/pulse-*/modules/module-router.so \
+"
+
+
+FILES_${PN}-dbg += " \
+ ${libdir}/pulse-*/modules/.debug/module-router.so \
+"
+
+