summaryrefslogtreecommitdiffstats
path: root/meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb')
-rw-r--r--meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb b/meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb
new file mode 100644
index 00000000..af7db3ac
--- /dev/null
+++ b/meta-agl-extra/meta-blsched/recipes-core/blsched/blsched_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "big.LITTLE scheduler"
+HOMEPAGE = "https://github.com/BayLibre/bLsched"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b0df75b2edb80ee98b732ee0514a265c"
+
+SRC_URI = "git://github.com/baylibre/blsched.git \
+ file://blsched.service \
+ "
+
+SRCREV = "b6bf199bc2def486857fb7003a6cb07708ed685e"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+COMPATIBLE_MACHINE ="((h|m)3ulcb|salvator-x)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+DAEMONARGS_r8a7795 = "-b 0 -b 1 -b 2 -b 3"
+DAEMONARGS_r8a7796 = "-b 0 -b 1"
+
+RDEPENDS_${PN} += " blsched"
+
+inherit systemd
+
+SYSTEMD_SERVICE_${PN} = "blsched.service"
+
+do_install_append () {
+ # Install the systemd init file
+ install -d ${D}${systemd_unitdir}/system
+ install -c -m 0644 ${WORKDIR}/blsched.service ${D}${systemd_unitdir}/system
+
+ sed -i -e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@ARGS@,${DAEMONARGS},g' \
+ ${D}${systemd_unitdir}/system/*.service
+}