summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-basesystem/conf
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-16 20:16:57 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-16 20:16:57 +0200
commitaadeb8892bd10afe952fce02a8a6abd4fa9f0ea4 (patch)
treefaf81d36f775cb4d4e063ffb9c5acb96758f2a71 /meta-agl/meta-agl-basesystem/conf
parent2bad39b645c4166c3a32eb56cf8a2ba90ce5584b (diff)
Diff of the 8.0.2 code-drop against stock AGL 8.0.2sandbox/jsmoeller/diff_to_halibut_8.0.2
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/meta-agl-basesystem/conf')
-rw-r--r--meta-agl/meta-agl-basesystem/conf/include/agl-basesystem-base.inc18
-rw-r--r--meta-agl/meta-agl-basesystem/conf/layer.conf16
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-agl/meta-agl-basesystem/conf/include/agl-basesystem-base.inc b/meta-agl/meta-agl-basesystem/conf/include/agl-basesystem-base.inc
new file mode 100644
index 00000000..b8f14408
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/conf/include/agl-basesystem-base.inc
@@ -0,0 +1,18 @@
+# AGL specific package configuration
+#
+# Add systemd configuration
+DISTRO_FEATURES_append = " systemd ${DISTRO_FEATURES_LIBC}"
+#VIRTUAL-RUNTIME_init_manager = "systemd"
+
+TOOLCHAIN_HOST_TASK_append += " nativesdk-os-rpclibrary-tool nativesdk-perl-module-app-cpan nativesdk-perl-module-json-pp"
+
+# add the static lib to SDK toolchain
+SDKIMAGE_FEATURES_append += " staticdev-pkgs dev-pkgs tools-debug tools-profile headerfiles-pkgs nativesdk-os-rpclibrary-tool"
+SDKIMAGE_FEATURES_remove += " dbg-pkgs"
+EXTRA_IMAGE_FEATURES_append += " staticdev-pkgs dev-pkgs dbg-pkgs tools-profile"
+
+# for agl-basefiles recipe
+IMAGE_INSTALL_append += "\
+ packagegroup-agl-basesystem \
+"
+
diff --git a/meta-agl/meta-agl-basesystem/conf/layer.conf b/meta-agl/meta-agl-basesystem/conf/layer.conf
new file mode 100644
index 00000000..d983f9fa
--- /dev/null
+++ b/meta-agl/meta-agl-basesystem/conf/layer.conf
@@ -0,0 +1,16 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbclass \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "agl-basesystem"
+BBFILE_PATTERN_agl-basesystem = "^${LAYERDIR}/"
+BBFILE_PRIORITY_agl-basesystem = "70"
+
+# for agl-basefiles recipe
+HOSTTOOLS += "xpath"
+
+LAYERSERIES_COMPAT_agl-basesystem = "thud"