summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb')
-rw-r--r--meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb b/meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
new file mode 100644
index 00000000..a3f67004
--- /dev/null
+++ b/meta-agl/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "AWS IoT device SDK for embedded C"
+AUTHOR = "AWS"
+HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-embedded-C"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
+
+SRC_URI = "\
+ git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https \
+ file://Makefile.aws \
+ file://aws_iot_config.h \
+ file://awsiotsdk.pc \
+"
+SRCREV = "d039f075e1cc2a2a7fc20edc6868f328d8d36b2f"
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+DEPENDS = "mbedtls"
+RDEPENDS_${PN} += "mbedtls"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/Makefile.aws ${S}/src
+ cp ${WORKDIR}/aws_iot_config.h ${S}/include
+ cp ${WORKDIR}/awsiotsdk.pc ${S}
+}
+
+do_compile() {
+ cd ${S}/src
+ oe_runmake -f ./Makefile.aws DESTDIR=${D} all
+}
+
+do_install() {
+ cd ${S}/src
+ oe_runmake -f ./Makefile.aws DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+ALLOW_EMPTY_${PN} = "1"
+