summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core/recipes-apis
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /meta-agl/meta-agl-profile-core/recipes-apis
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'meta-agl/meta-agl-profile-core/recipes-apis')
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb6
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb27
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb8
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend5
-rwxr-xr-xmeta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb3
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb5
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb19
7 files changed, 56 insertions, 17 deletions
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
index 91c6b75c..d06cfd26 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-can-low-level/agl-service-can-low-level_git.bb
@@ -7,13 +7,13 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "087a7c0e7de28bb1c16895ef9d414666d37a35ea"
+SRCREV = "${AGL_APP_REVISION}"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-DEPENDS = "libafb-helpers"
-RDEPENDS_${PN} = "dev-mapping"
+DEPENDS = "libafb-helpers libappcontroller"
inherit cmake aglwgt pkgconfig ptest
+RDEPENDS_${PN} = "virtual/low-can-dev-mapping"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
new file mode 100644
index 00000000..e4dccbf3
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "HVAC Service Binding Configuration"
+DESCRIPTION = "AGL HVAC Service Binding Configuration"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
+do_install_append_ulcb() {
+ sed -i -e "s#vcan0#sllin0#g" ${D}${sysconfdir}/hvac.json
+}
+
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
index f5dc0814..545ab6a2 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bb
@@ -13,10 +13,8 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
DEPENDS = "json-c"
-RDEPENDS_${PN} += "agl-service-identity-agent"
-
-do_install_append () {
- install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
-}
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "agl-service-identity-agent agl-service-can-low-level"
+RRECOMMENDS_${PN} += "agl-service-hvac-conf"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
deleted file mode 100644
index 0817d5ed..00000000
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-# for demo
-PACKAGE_ARCH_m3ulcb = "${MACHINE_ARCH}"
-do_configure_prepend_m3ulcb() {
-sed -i -e "s#vcan0#sllin0#g" ${S}/binding/hvac-demo-binding.c
-} \ No newline at end of file
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
index c7a6fce0..71a615cf 100755
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
@@ -1,6 +1,5 @@
SUMMARY = "Navigation Service Binding"
DESCRIPTION = "AGL Navigation Service API Binding"
-HOMEPAGE = "https://github.com/AGLExport/agl-service-navigation"
SECTION = "apps"
LICENSE = "Apache-2.0"
@@ -15,3 +14,5 @@ PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "json-c libdbus-c++"
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
index 742a7f7f..bf714f45 100644
--- a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-signal-composer/agl-service-signal-composer_git.bb
@@ -11,9 +11,8 @@ inherit cmake pkgconfig aglwgt ptest
DEPENDS += "lua lua-native libappcontroller libafb-helpers"
RDEPENDS_${PN} += "lua"
-SRC_URI = "gitsm://git.automotivelinux.org/apps/agl-service-signal-composer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "fe311f49703e9691fa7d515ed84a70b996f7f3e8"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-signal-composer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
-
diff --git a/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
new file mode 100644
index 00000000..85ebc90f
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Infotainment network device control"
+DESCRIPTION = "Abstraction layer to control INICnet devices"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-unicens-controller"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-unicens-controller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt pkgconfig
+
+DEPENDS += "json-c af-binder libafb-helpers"
+RDEPENDS_${PN} += "agl-service-unicens"
+