summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend')
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend22
1 files changed, 3 insertions, 19 deletions
diff --git a/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index 17ad0558..ad422eb5 100644
--- a/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,21 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-def prep_version (d) :
- KV = d.getVar('KERNEL_VERSION', True)
- if not KV :
- return "4.12"
- else:
- return KV
-
-ORIG_KERN_VER = "${@prep_version(d)}"
-
-VANILLA_KERNEL_VERSION = "${@str(ORIG_KERN_VER.split("-")[0].split(".")[0]+ORIG_KERN_VER.split("-")[0].split(".")[1])}"
-
-APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
-APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
-
SRC_URI_append = " \
- file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
file://0002-src-most-add-auto-conf-feature.patch \
file://0003-core-remove-kernel-log-for-MBO-status.patch \
file://0004-most-video-set-device_caps.patch \
@@ -25,7 +10,6 @@ SRC_URI_append = " \
file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
- "
-# Make sure we can expose KERNEL_VERSION ...
-do_patch[depends] += "virtual/kernel:do_populate_sysroot"
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
+ file://0012-Fix-build-with-5.4-kernel.patch \
+"