summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb')
-rw-r--r--meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
new file mode 100644
index 00000000..db6f7dee
--- /dev/null
+++ b/meta-agl/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "bc241e850fa1d2ceeb76acd9bac8733868392baa"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-asyncio \
+ python3-asyncssh \
+ python3-core \
+ python3-json \
+ python3-logging \
+ python3-math \
+ python3-parse \
+ python3-pprint \
+ python3-pytest \
+ python3-pytest-asyncio \
+ python3-pytest-dependency \
+ python3-pytest-reverse \
+ python3-typing \
+ python3-websockets \
+"