summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-app-framework/conf
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /meta-agl/meta-app-framework/conf
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'meta-agl/meta-app-framework/conf')
-rw-r--r--meta-agl/meta-app-framework/conf/include/agl-appfw-smack.inc18
-rw-r--r--meta-agl/meta-app-framework/conf/layer.conf12
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl/meta-app-framework/conf/include/agl-appfw-smack.inc b/meta-agl/meta-app-framework/conf/include/agl-appfw-smack.inc
new file mode 100644
index 00000000..b6b998a9
--- /dev/null
+++ b/meta-agl/meta-app-framework/conf/include/agl-appfw-smack.inc
@@ -0,0 +1,18 @@
+# enable security features (smack, cynara) - required by Application Framework
+OVERRIDES .= ":with-lsm-smack"
+DISTRO_FEATURES_append = " smack xattr"
+
+# use tar-native to support SMACK extended attributes independently of host config
+IMAGE_CMD_TAR = "tar --xattrs --xattrs-include='*'"
+do_image_tar[depends] += "tar-replacement-native:do_populate_sysroot"
+EXTRANATIVEPATH += "tar-native"
+
+# security: enable ssh server in place of dropbear to support PAM on user sessions
+IMAGE_FEATURES += "ssh-server-openssh"
+
+# enforce copy of xattrs (to be removed, see SPEC-475)
+PACKAGECONFIG_append_pn-shadow = " attr"
+PACKAGECONFIG_append_pn-shadow-native = " attr"
+
+# set the home directory for root
+ROOT_HOME = "/home/0"
diff --git a/meta-agl/meta-app-framework/conf/layer.conf b/meta-agl/meta-app-framework/conf/layer.conf
new file mode 100644
index 00000000..4af5354a
--- /dev/null
+++ b/meta-agl/meta-app-framework/conf/layer.conf
@@ -0,0 +1,12 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "app-framework"
+BBFILE_PATTERN_app-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_app-framework = "70"
+
+LAYERSERIES_COMPAT_app-framework = "thud"