summaryrefslogtreecommitdiffstats
path: root/meta-agl/meta-app-framework/recipes-core
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /meta-agl/meta-app-framework/recipes-core
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'meta-agl/meta-app-framework/recipes-core')
-rw-r--r--meta-agl/meta-app-framework/recipes-core/af-binder/af-binder_git.inc2
-rw-r--r--meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb8
-rw-r--r--meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.inc7
-rw-r--r--meta-agl/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb1
-rw-r--r--meta-agl/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb4
5 files changed, 14 insertions, 8 deletions
diff --git a/meta-agl/meta-app-framework/recipes-core/af-binder/af-binder_git.inc b/meta-agl/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
index ffe4765e..fbaa47bc 100644
--- a/meta-agl/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
+++ b/meta-agl/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "b15edc1c48d74f2ad6e9ade577bf6b4945d85eee"
+SRCREV = "1b6249810b3ab2d0c7467355fa22fbf19ae4a725"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 66b93db5..917eaa41 100644
--- a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -16,7 +16,7 @@ RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
-EXTRA_OECMAKE_class-native = "\
+EXTRA_OECMAKE_append_class-native = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=1 \
-DUSE_SDK=1 \
@@ -26,7 +26,7 @@ EXTRA_OECMAKE_class-native = "\
-Dafm_datadir=${afm_datadir} \
"
-EXTRA_OECMAKE = "\
+EXTRA_OECMAKE_append_class-target = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \
-DUSE_SDK=0 \
@@ -85,9 +85,6 @@ do_install_append_class-target() {
ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
-
- DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
- echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
}
pkg_postinst_ontarget_${PN}() {
@@ -114,6 +111,7 @@ pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
chsmack -a 'System::Shared' -t $D${afm_datadir}/icons
}
FILES_${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
+FILES_${PN}_append_agl-sign-wgts = " ${datadir}/afm"
PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
diff --git a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.inc b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.inc
index df06df63..7eb94b23 100644
--- a/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.inc
+++ b/meta-agl/meta-app-framework/recipes-core/af-main/af-main_git.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "381a0973c9d421bc031882cecce9244f6d2a6638"
+SRCREV = "af8db35cc01c57b7d1d2e4fa7815df8c16f8454f"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -22,4 +22,9 @@ afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/var/local/lib/systemd"
CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+# only install sample keys in agl-devel mode
+# for production you need to deploy real keys
+EXTRA_OECMAKE_append_agl-sign-wgts = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '-DINSTALL_SAMPLE_KEYS=ON', '-DINSTALL_SAMPLE_KEYS=OFF', d)}"
+
+
diff --git a/meta-agl/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb b/meta-agl/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
index 759c893c..88ab4ae6 100644
--- a/meta-agl/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
+++ b/meta-agl/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
@@ -23,5 +23,6 @@ do_install_append() {
PACKAGES = "${PN}-tools ${PN}-tools-dbg"
FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools_append_agl-sign-wgts = " ${datadir}/afm"
FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
diff --git a/meta-agl/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb b/meta-agl/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
index 62e163f9..45861f7c 100644
--- a/meta-agl/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
+++ b/meta-agl/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
@@ -13,6 +13,8 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/nss-localuser;protocol=ht
SRCREV = "66803c6fdb609ed83a78b9194ecb23e9c1b773e7"
PV = "${AGL_BRANCH}+git${SRCPV}"
+RDEPENDS_${PN} = "base-files"
+
S = "${WORKDIR}/git"
do_compile() {
@@ -23,7 +25,7 @@ do_install() {
make nssdir=${D}${libdir} install
}
-pkg_postinst_${PN} () {
+pkg_postinst_ontarget_${PN} () {
sed -e '/^hosts:/s/\<localuser\>\s*//' \
-e 's/\(^hosts:\s\s*\)\(.*\)/\1localuser \2/' \
-i $D${sysconfdir}/nsswitch.conf