summaryrefslogtreecommitdiffstats
path: root/bsp/meta-altera
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-altera')
-rw-r--r--bsp/meta-altera/README.md33
-rw-r--r--bsp/meta-altera/conf/layer.conf2
-rw-r--r--bsp/meta-altera/conf/machine/10m50.conf2
-rw-r--r--bsp/meta-altera/conf/machine/agilex.conf25
-rw-r--r--bsp/meta-altera/conf/machine/arria10.conf14
-rw-r--r--bsp/meta-altera/conf/machine/arria5.conf4
-rw-r--r--bsp/meta-altera/conf/machine/cyclone5.conf11
-rw-r--r--bsp/meta-altera/conf/machine/include/socfpga.inc3
-rw-r--r--bsp/meta-altera/conf/machine/include/socfpga_armv8a.inc9
-rw-r--r--bsp/meta-altera/conf/machine/stratix10.conf5
-rw-r--r--bsp/meta-altera/conf/machine/stratix10swvp.conf39
-rw-r--r--bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga-common.inc18
-rw-r--r--bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb2
-rw-r--r--bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb2
-rw-r--r--bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb7
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/config/config_gpio_sys.cfg1
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/config/config_jffs2.cfg2
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/config/gpio_sys.scc1
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/config/jffs2.scc1
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.3.bb15
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.bb (renamed from bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.13.bb)7
-rw-r--r--bsp/meta-altera/recipes-kernel/linux/linux-altera_5.5.bb (renamed from bsp/meta-altera/recipes-kernel/linux/linux-altera_5.2.bb)4
-rw-r--r--bsp/meta-altera/wic/sdimage-stratix10-agilex.wks (renamed from bsp/meta-altera/wic/sdimage-stratix10.wks)0
23 files changed, 114 insertions, 93 deletions
diff --git a/bsp/meta-altera/README.md b/bsp/meta-altera/README.md
index cea1dbf6..532333bc 100644
--- a/bsp/meta-altera/README.md
+++ b/bsp/meta-altera/README.md
@@ -4,6 +4,18 @@ This layer works with poky and Angstrom
Please follow the recommended setup procedures of your OE distribution.
+Supported u-boot and linux kernels
+===
+It is important to understand the support and release of u-boot-socfpga
+and linux-socfpga in the github.com/altera-opensource repositories. Only
+currently supported and maintained releases/branches are available in the
+repository. As such, supported kernel and u-boot releases are updated regularly
+in currently supported meta-altera branches. Kernel and u-boot releases
+which are no longer supported are removed.
+
+Supported branches
+==================
+Only branches listed appropriately in https://wiki.yoctoproject.org/wiki/Stable_branch_maintenance are maintained.
Choosing Kernel Versions
==========================
@@ -25,6 +37,21 @@ or for the linux-altera-ltsi kernel
Please note that older kernels will not compile with GCC 5+ and you will need
to specify in your conf/local.conf to revert to older 4.9 toolchain.
+Specifying Devicetrees and U-Boot Configurations
+==================================================
+All of the supported machines select default uboot configurations and devicetrees. These
+selections can be overridden in the local.conf or by defining your own machine in your
+own layer.
+
+An example of the is the DE0-Nano-SoC board, which is a supported configuration in the Cyclone5
+machine definition.
+
+ UBOOT_CONFIG = "de0-nano-soc"
+ UBOOT_EXTLINUX_FDT_default = "../socfpga_cyclone5_de0_nano_soc.dtb"
+
+The above overrides the uboot configuration, "de0-nano-soc" is a target in u-boot, and configures
+distroboot to indicate the de0-nano-soc devicetree. Please keep in mind that not all targets are
+using distroboot in u-boot and may require u-boot environment changes.
Choosing Toolchain Versions
=============================
@@ -48,8 +75,6 @@ For Angstrom:
-Send pull requests, patches, comments or questions to yvanderv@opensource.altera.com
-and raj.khem@gmail.com
+Submit patches via github pull requests, Use github issues to report problems or to send comments
-Maintainers: Khem Raj <raj.khem@gmail.com>
- Yves Vandervennet <yves.vandervennet@intel.com>
+Maintainer(s): Khem Raj <raj.khem@gmail.com>
diff --git a/bsp/meta-altera/conf/layer.conf b/bsp/meta-altera/conf/layer.conf
index 1ce4d2d5..a9885b2f 100644
--- a/bsp/meta-altera/conf/layer.conf
+++ b/bsp/meta-altera/conf/layer.conf
@@ -8,7 +8,7 @@ BBFILE_COLLECTIONS += "meta-altera"
BBFILE_PATTERN_meta-altera := "^${LAYERDIR}/"
# increase the number
BBFILE_PRIORITY_meta-altera = "6"
-LAYERSERIES_COMPAT_meta-altera = "thud"
+LAYERSERIES_COMPAT_meta-altera = "warrior zeus dunfell"
# yves
BBDEBUG = "yes"
diff --git a/bsp/meta-altera/conf/machine/10m50.conf b/bsp/meta-altera/conf/machine/10m50.conf
index dadcbbd4..36dcf771 100644
--- a/bsp/meta-altera/conf/machine/10m50.conf
+++ b/bsp/meta-altera/conf/machine/10m50.conf
@@ -18,6 +18,8 @@ KERNEL_DEVICETREE = "10m50_devboard.dtb"
MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
MACHINE_FEATURES = "kernel26 serial"
+KBUILD_DEFCONFIG ?= "10m50_defconfig"
+
SERIAL_CONSOLE = "115200 ttyS0"
PREFERRED_PROVIDER_virtual/kernel ??= "linux-altera-ltsi"
diff --git a/bsp/meta-altera/conf/machine/agilex.conf b/bsp/meta-altera/conf/machine/agilex.conf
new file mode 100644
index 00000000..d9061534
--- /dev/null
+++ b/bsp/meta-altera/conf/machine/agilex.conf
@@ -0,0 +1,25 @@
+#@TYPE: Machine
+#@NAME: Altera Agilex
+#@DESCRIPTION: Layer for the Intel PSG Agilex
+
+KBUILD_DEFCONFIG ?= "defconfig"
+
+require conf/machine/include/socfpga_armv8a.inc
+
+UBOOT_CONFIG ??= "agilex-socdk"
+
+KERNEL_DEVICETREE ?= "intel/socfpga_agilex_socdk.dtb"
+
+SERIAL_CONSOLES ?= "115200;ttyS0"
+
+EXTRA_IMAGECMD_jffs2 ?= "-n -q -e 0x10000"
+
+# Add variables for wic creation of sdcard image
+IMAGE_BOOT_FILES ?= " \
+ ${UBOOT_BINARY} \
+ ${KERNEL_IMAGETYPE} \
+ socfpga_agilex_socdk.dtb \
+ "
+WKS_FILE ?= "sdimage-stratix10-agilex.wks"
+IMAGE_FSTYPES += "wic"
+
diff --git a/bsp/meta-altera/conf/machine/arria10.conf b/bsp/meta-altera/conf/machine/arria10.conf
index 249edcc6..eb1367b9 100644
--- a/bsp/meta-altera/conf/machine/arria10.conf
+++ b/bsp/meta-altera/conf/machine/arria10.conf
@@ -4,17 +4,11 @@
require conf/machine/include/socfpga.inc
-PREFERRED_VERSION_u-boot-socfpga ?= "v2019.07%"
-
SPL_BINARY = "u-boot-with-spl.sfp"
-UBOOT_BINARY = "u-boot-dtb.img"
+UBOOT_BINARY = "u-boot.img"
UBOOT_CONFIG ??= "arria10-socdk"
-UBOOT_CONFIG[arria10-socdk] = "socfpga_arria10_defconfig"
-UBOOT_CONFIG[arria10-socdk-nand] = "socfpga_arria10_nand_defconfig"
-UBOOT_CONFIG[arria10-socdk-qspi] = "socfpga_arria10_qspi_defconfig"
-
KMACHINE = "arria10"
# Default kernel devicetrees
@@ -23,7 +17,11 @@ KERNEL_DEVICETREE ?= "\
socfpga_arria10_socdk_qspi.dtb \
socfpga_arria10_socdk_nand.dtb \
"
-EXTRA_IMAGECMD_jffs2 = "--squash -s 256 -e 64KiB"
+
+EXTRA_IMAGECMD_jffs2 ?= "-n -q \
+ ${@bb.utils.contains("A10_IMAGE_TYPE", "NAND", "-e 0x20000 -s 0x200", "", d)} \
+ ${@bb.utils.contains("A10_IMAGE_TYPE", "QSPI", "-e 0x10000", "", d)} \
+ "
SERIAL_CONSOLES ?= "115200;ttyS0"
diff --git a/bsp/meta-altera/conf/machine/arria5.conf b/bsp/meta-altera/conf/machine/arria5.conf
index 01cc58b4..bf0b3156 100644
--- a/bsp/meta-altera/conf/machine/arria5.conf
+++ b/bsp/meta-altera/conf/machine/arria5.conf
@@ -4,12 +4,8 @@
require conf/machine/include/socfpga.inc
-PREFERRED_VERSION_u-boot-socfpga ?= "v2019.01%"
-
UBOOT_CONFIG ??= "arria5-socdk"
-UBOOT_CONFIG[arria5-socdk] = "socfpga_arria5_defconfig"
-
KMACHINE = "arria5"
# Default kernel devicetrees
diff --git a/bsp/meta-altera/conf/machine/cyclone5.conf b/bsp/meta-altera/conf/machine/cyclone5.conf
index bee250bf..13f5c8da 100644
--- a/bsp/meta-altera/conf/machine/cyclone5.conf
+++ b/bsp/meta-altera/conf/machine/cyclone5.conf
@@ -4,17 +4,8 @@
require conf/machine/include/socfpga.inc
-PREFERRED_VERSION_u-boot-socfpga ?= "v2019.01%"
-
UBOOT_CONFIG ??= "cyclone5-socdk"
-UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_defconfig"
-UBOOT_CONFIG[de0-nano-soc] = "socfpga_de0_nano_soc_defconfig"
-UBOOT_CONFIG[mcvevk] = "socfpga_mcvevk_defconfig"
-UBOOT_CONFIG[sockit] = "socfpga_sockit_defconfig"
-UBOOT_CONFIG[socrates] = "socfpga_socrates_defconfig"
-UBOOT_CONFIG[sr1500] = "socfpga_sr1500_defconfig"
-
KMACHINE = "cyclone5"
# Default kernel devicetrees
@@ -47,6 +38,8 @@ IMAGE_BOOT_FILES ?= " \
extlinux.conf;extlinux/extlinux.conf \
"
+EXTRA_IMAGECMD_jffs2 ?= "-e 0x10000"
+
WKS_FILE ?= "sdimage-cyclone5-arria5.wks"
IMAGE_FSTYPES +="wic"
diff --git a/bsp/meta-altera/conf/machine/include/socfpga.inc b/bsp/meta-altera/conf/machine/include/socfpga.inc
index 256c0084..3b36bbcb 100644
--- a/bsp/meta-altera/conf/machine/include/socfpga.inc
+++ b/bsp/meta-altera/conf/machine/include/socfpga.inc
@@ -9,6 +9,7 @@ KERNEL_PROVIDER ?= "linux-altera"
PREFERRED_PROVIDER_virtual/kernel ?= "${KERNEL_PROVIDER}"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-socfpga"
+PREFERRED_PROVIDER_u-boot ?= "u-boot-socfpga"
# Increase this everytime you change something in the kernel
MACHINE_KERNEL_PR = "r1"
@@ -20,6 +21,8 @@ KERNEL_IMAGETYPE ?= "zImage"
MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
MACHINE_FEATURES = "kernel26"
+KBUILD_DEFCONFIG ?= "socfpga_defconfig"
+
# file system images required
IMAGE_FSTYPES ?= "cpio ext3 tar.gz jffs2"
diff --git a/bsp/meta-altera/conf/machine/include/socfpga_armv8a.inc b/bsp/meta-altera/conf/machine/include/socfpga_armv8a.inc
index 766b7293..40f93536 100644
--- a/bsp/meta-altera/conf/machine/include/socfpga_armv8a.inc
+++ b/bsp/meta-altera/conf/machine/include/socfpga_armv8a.inc
@@ -1,16 +1,19 @@
-require conf/machine/include/arm/arch-armv8.inc
+require conf/machine/include/arm/arch-armv8a.inc
KERNEL_PROVIDER ?= "linux-altera"
PREFERRED_PROVIDER_virtual/kernel ?= "${KERNEL_PROVIDER}"
KERNEL_IMAGETYPE = "Image"
MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+KBUILD_DEFCONFIG ?= "defconfig"
+
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-socfpga"
+PREFERRED_PROVIDER_u-boot ?= "u-boot-socfpga"
SPL_BINARY = "spl/u-boot-spl-dtb.hex"
UBOOT_SUFFIX = "img"
-UBOOT_BINARY = "u-boot-dtb.img"
-UBOOT_IMAGE = "u-boot-dtb-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY = "u-boot.img"
+UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
IMAGE_FSTYPES ?= "cpio ext3 tar.gz"
do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot virtual/bootloader:do_deploy virtual/kernel:do_deploy"
diff --git a/bsp/meta-altera/conf/machine/stratix10.conf b/bsp/meta-altera/conf/machine/stratix10.conf
index a3ca1f77..4b4ad3a0 100644
--- a/bsp/meta-altera/conf/machine/stratix10.conf
+++ b/bsp/meta-altera/conf/machine/stratix10.conf
@@ -5,18 +5,19 @@
require conf/machine/include/socfpga_armv8a.inc
UBOOT_CONFIG ??= "stratix10-socdk"
-UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig"
KERNEL_DEVICETREE ?= "altera/socfpga_stratix10_socdk.dtb"
SERIAL_CONSOLES ?= "115200;ttyS0"
+EXTRA_IMAGECMD_jffs2 ?= "-n -q -e 0x10000"
+
# Add variables for wic creation of sdcard image
IMAGE_BOOT_FILES ?= " \
${UBOOT_BINARY} \
${KERNEL_IMAGETYPE} \
socfpga_stratix10_socdk.dtb \
"
-WKS_FILE ?= "sdimage-stratix10.wks"
+WKS_FILE ?= "sdimage-stratix10-agilex.wks"
IMAGE_FSTYPES += "wic"
diff --git a/bsp/meta-altera/conf/machine/stratix10swvp.conf b/bsp/meta-altera/conf/machine/stratix10swvp.conf
deleted file mode 100644
index c7b664fa..00000000
--- a/bsp/meta-altera/conf/machine/stratix10swvp.conf
+++ /dev/null
@@ -1,39 +0,0 @@
-#@TYPE: Machine
-#@NAME: Altera Stratix10 SWVP
-#@DESCRIPTION: Layer for the Altera Stratix10 Software Virtual Platform
-
-require conf/machine/include/arm/arch-armv8.inc
-
-PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
-
-XSERVER ?= "xserver-xorg \
- mesa-driver-swrast \
- xf86-input-evdev \
- xf86-input-mouse \
- xf86-video-fbdev \
- xf86-input-keyboard"
-
-MACHINE_FEATURES = ""
-
-# Don't include kernels in standard images
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
-
-KERNEL_PROVIDER ?= "linux-altera"
-PREFERRED_PROVIDER_virtual/kernel ?= "${KERNEL_PROVIDER}"
-
-KERNEL_IMAGETYPE = "Image"
-
-# We have to disable SERIAL_CONSOLE due to auto-serial-console
-#SERIAL_CONSOLE = "115200 ttyAMA0"
-
-# Force auto-serial-console to be used by all image types
-# Ideally this would be part of core oe or as a bbclassappend,
-# but as we don't have an easy way to append a class, defining
-# it here
-EXTRA_IMAGE_FEATURES += "autoserial"
-FEATURE_PACKAGES_autoserial = "auto-serial-console"
-
-# we do not want to have getty running on tty1 as we run
-# auto-serial-console there
-#USE_VT = "0"
-IMAGE_FSTYPES ?= "cpio ext3 tar.gz"
diff --git a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga-common.inc b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga-common.inc
index 2038545e..def29fa7 100644
--- a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga-common.inc
+++ b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga-common.inc
@@ -10,4 +10,20 @@ PV_append = "+git${SRCPV}"
S = "${WORKDIR}/git"
-RPROVIDES_${PN} += "u-boot"
+RPROVIDES_${PN} += "u-boot"
+
+UBOOT_CONFIG[agilex-socdk] = "socfpga_agilex_defconfig"
+UBOOT_CONFIG[agilex-socdk-qspi] = "socfpga_agilex_qspi_defconfig"
+UBOOT_CONFIG[stratix10-socdk] = "socfpga_stratix10_defconfig"
+UBOOT_CONFIG[stratix10-socdk-qspi] = "socfpga_stratix10_qspi_defconfig"
+UBOOT_CONFIG[arria10-socdk] = "socfpga_arria10_defconfig"
+UBOOT_CONFIG[arria10-socdk-nand] = "socfpga_arria10_nand_defconfig"
+UBOOT_CONFIG[arria10-socdk-qspi] = "socfpga_arria10_qspi_defconfig"
+UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_defconfig"
+UBOOT_CONFIG[de0-nano-soc] = "socfpga_de0_nano_soc_defconfig"
+UBOOT_CONFIG[de10-nano-soc] = "socfpga_de10_nano_defconfig"
+UBOOT_CONFIG[mcvevk] = "socfpga_mcvevk_defconfig"
+UBOOT_CONFIG[sockit] = "socfpga_sockit_defconfig"
+UBOOT_CONFIG[socrates] = "socfpga_socrates_defconfig"
+UBOOT_CONFIG[sr1500] = "socfpga_sr1500_defconfig"
+UBOOT_CONFIG[arria5-socdk] = "socfpga_arria5_defconfig"
diff --git a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
index 8c7ec331..790eca13 100644
--- a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
+++ b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.04.bb
@@ -2,6 +2,6 @@ require u-boot-socfpga-common.inc
require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.04"
-SRCREV = "83e929c739beecff17529a0cf0fdd5c74fbe3c72"
+SRCREV = "6296fdb7da9e205bc34416f38631715fb6d74e71"
DEPENDS += "dtc-native bc-native u-boot-mkimage-native"
diff --git a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
index 9176f9ac..a42659a0 100644
--- a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
+++ b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2019.10.bb
@@ -2,6 +2,6 @@ require u-boot-socfpga-common.inc
require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2019.10"
-SRCREV = "7298985146c70ca8af8d43dd963b3e8aa3900d87"
+SRCREV = "34638cc921269665e43340a50552302bd358f793"
DEPENDS += "dtc-native bc-native u-boot-mkimage-native"
diff --git a/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb
new file mode 100644
index 00000000..5e3d99b1
--- /dev/null
+++ b/bsp/meta-altera/recipes-bsp/u-boot/u-boot-socfpga_v2020.04.bb
@@ -0,0 +1,7 @@
+require u-boot-socfpga-common.inc
+require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
+
+SRC_URI = "git://github.com/altera-opensource/u-boot-socfpga.git;branch=socfpga_v2020.04"
+SRCREV = "2cbc36afbb31bee6e245291c51c283dbde0e3b89"
+
+DEPENDS += "dtc-native bc-native u-boot-mkimage-native"
diff --git a/bsp/meta-altera/recipes-kernel/linux/config/config_gpio_sys.cfg b/bsp/meta-altera/recipes-kernel/linux/config/config_gpio_sys.cfg
new file mode 100644
index 00000000..52708d18
--- /dev/null
+++ b/bsp/meta-altera/recipes-kernel/linux/config/config_gpio_sys.cfg
@@ -0,0 +1 @@
+CONFIG_GPIO_SYSFS=y
diff --git a/bsp/meta-altera/recipes-kernel/linux/config/config_jffs2.cfg b/bsp/meta-altera/recipes-kernel/linux/config/config_jffs2.cfg
new file mode 100644
index 00000000..b820ba7b
--- /dev/null
+++ b/bsp/meta-altera/recipes-kernel/linux/config/config_jffs2.cfg
@@ -0,0 +1,2 @@
+CONFIG_JFFS2_FS=y
+CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=n
diff --git a/bsp/meta-altera/recipes-kernel/linux/config/gpio_sys.scc b/bsp/meta-altera/recipes-kernel/linux/config/gpio_sys.scc
new file mode 100644
index 00000000..816cf611
--- /dev/null
+++ b/bsp/meta-altera/recipes-kernel/linux/config/gpio_sys.scc
@@ -0,0 +1 @@
+kconf non-hardware config_gpio_sys.cfg
diff --git a/bsp/meta-altera/recipes-kernel/linux/config/jffs2.scc b/bsp/meta-altera/recipes-kernel/linux/config/jffs2.scc
new file mode 100644
index 00000000..563ac172
--- /dev/null
+++ b/bsp/meta-altera/recipes-kernel/linux/config/jffs2.scc
@@ -0,0 +1 @@
+kconf non-hardware config_jffs2.cfg
diff --git a/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.3.bb b/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.3.bb
deleted file mode 100644
index 65b522b9..00000000
--- a/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.3.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-LINUX_VERSION = "5.4.3"
-LINUX_VERSION_SUFFIX = "-lts"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-
-SRCREV = "d2466b12e55dda297f3b1a4787b5ea3160994ee9"
-
-include linux-altera.inc
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/config:"
-
-SRC_URI_append_cyclone5 = " file://lbdaf.scc "
-SRC_URI_append_arria5 = " file://lbdaf.scc "
-SRC_URI_append_arria10 = " file://lbdaf.scc "
-
diff --git a/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.13.bb b/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.bb
index 1ddccee0..3376bc65 100644
--- a/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.13.bb
+++ b/bsp/meta-altera/recipes-kernel/linux/linux-altera-lts_5.4.bb
@@ -1,9 +1,9 @@
-LINUX_VERSION = "5.4.13"
+LINUX_VERSION = "5.4.44"
LINUX_VERSION_SUFFIX = "-lts"
LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-SRCREV = "44239fc38eaefd29c66ec3bb4a547b1a4541bb13"
+SRCREV = "bafc8df26aa0b0b11927ac3649a86c5c3dabf90d"
include linux-altera.inc
@@ -12,4 +12,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/config:"
SRC_URI_append_cyclone5 = " file://lbdaf.scc "
SRC_URI_append_arria5 = " file://lbdaf.scc "
SRC_URI_append_arria10 = " file://lbdaf.scc "
-
+SRC_URI_append_stratix10 = " file://jffs2.scc file://gpio_sys.scc "
+SRC_URI_append_agilex = " file://jffs2.scc file://gpio_sys.scc "
diff --git a/bsp/meta-altera/recipes-kernel/linux/linux-altera_5.2.bb b/bsp/meta-altera/recipes-kernel/linux/linux-altera_5.5.bb
index 254dc896..b72210e4 100644
--- a/bsp/meta-altera/recipes-kernel/linux/linux-altera_5.2.bb
+++ b/bsp/meta-altera/recipes-kernel/linux/linux-altera_5.5.bb
@@ -1,6 +1,6 @@
-LINUX_VERSION = "5.2"
+LINUX_VERSION = "5.5"
-SRCREV = "969da0f16f5b914bd1e53e8c5051ef9df4f561f2"
+SRCREV = "d5aa6a79dc020e8bcfffb9b6ca6904b35c202501"
include linux-altera.inc
diff --git a/bsp/meta-altera/wic/sdimage-stratix10.wks b/bsp/meta-altera/wic/sdimage-stratix10-agilex.wks
index 3e04dac8..3e04dac8 100644
--- a/bsp/meta-altera/wic/sdimage-stratix10.wks
+++ b/bsp/meta-altera/wic/sdimage-stratix10-agilex.wks